GNS3 – DMVPN Example (dynamips)

 

Summary

R1 acts as the Hub with a static public IP, while R2, R3 and R4 are spokes that obtain an IP from the “ISP”.

Versions / Image Releases

GNS3: 2.1.5

R1,R2,R3,R4: c7200-adventerprisek9-mz.152-4.S5

ISP_Cloud: c3725-adventerprisek9-mz.124-15.T14 (as EtherSwitch Router)

Copy Pasta

R1:

hostname R1
interface FastEthernet0/0
 ip address 172.16.0.1 255.255.255.252
 no shutdown
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!
ip dhcp pool R1_Clients
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
!
interface Tunnel0
 ip address 10.0.0.1 255.255.255.0
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 no ip split-horizon eigrp 90
 no ip next-hop-self eigrp 90
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
!
router eigrp 90
 network 10.0.0.0 0.0.0.255
 network 192.168.1.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 172.16.0.2

R2:

hostname R2
interface FastEthernet0/0
 ip address dhcp
 no shutdown
interface FastEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 no shutdown
!
ip dhcp pool R2_Clients
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.1
!
interface Tunnel0
 ip address 10.0.0.2 255.255.255.0
 ip nhrp map 10.0.0.1 172.16.0.1
 ip nhrp map multicast 172.16.0.1
 ip nhrp network-id 1
 ip nhrp nhs 10.0.0.1
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
!
router eigrp 90
 network 10.0.0.0 0.0.0.255
 network 192.168.2.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

R3:

hostname R3
interface FastEthernet0/0
 ip address dhcp
 no shutdown
interface FastEthernet0/1
 ip address 192.168.3.1 255.255.255.0
 no shutdown
!
ip dhcp pool R2_Clients
 network 192.168.3.0 255.255.255.0
 default-router 192.168.3.1
!
interface Tunnel0
 ip address 10.0.0.3 255.255.255.0
 ip nhrp map 10.0.0.1 172.16.0.1
 ip nhrp map multicast 172.16.0.1
 ip nhrp network-id 1
 ip nhrp nhs 10.0.0.1
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
!
router eigrp 90
 network 10.0.0.0 0.0.0.255
 network 192.168.3.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

R4:

hostname R4
interface FastEthernet0/0
 ip address dhcp
 no shutdown
interface FastEthernet0/1
 ip address 192.168.4.1 255.255.255.0
 no shutdown
!
ip dhcp pool R2_Clients
 network 192.168.4.0 255.255.255.0
 default-router 192.168.4.1
!
interface Tunnel0
 ip address 10.0.0.4 255.255.255.0
 ip nhrp map 10.0.0.1 172.16.0.1
 ip nhrp map multicast 172.16.0.1
 ip nhrp network-id 1
 ip nhrp nhs 10.0.0.1
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
!
router eigrp 90
 network 10.0.0.0 0.0.0.255
 network 192.168.4.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ISP_Cloud:

vlan database
vlan 2
vlan 3
vlan 4
exit
!
conf t
hostname ISP_Cloud
interface FastEthernet1/0
 no switchport
 ip address 172.16.0.2 255.255.255.252
!
interface vlan 2
 ip address 22.0.0.1 255.0.0.0
 no shutdown
interface vlan 3
 ip address 33.0.0.1 255.0.0.0
 no shutdown
interface vlan 4
 ip address 44.0.0.1 255.0.0.0
 no shutdown
!
interface FastEthernet1/1
 switchport mode access
 switchport access vlan 2
interface FastEthernet1/2
 switchport mode access
 switchport access vlan 3
interface FastEthernet1/3
 switchport mode access
 switchport access vlan 4
!
service dhcp
ip dhcp pool R2_WAN
 network 22.0.0.0 255.0.0.0
 default-router 22.0.0.1
ip dhcp pool R3_WAN
 network 33.0.0.0 255.0.0.0
 default-router 33.0.0.1
ip dhcp pool R4_WAN
 network 44.0.0.0 255.0.0.0
 default-router 44.0.0.1
Unencrypted traffic

 

Add to all devices to enable IPSEC:

!--- ADD TO ALL TO SECURE
crypto isakmp policy 1
 authentication pre-share
crypto isakmp key P4ssw0rd address 0.0.0.0
!
crypto ipsec transform-set TransformSet1 esp-aes esp-sha-hmac
!
crypto ipsec profile Profile1
 set transform-set TransformSet1
!
interface Tunnel0
 tunnel protection ipsec profile Profile1
Secure Traffic

Download:

Leave a Reply

Your email address will not be published. Required fields are marked *